当前位置:首页 > 问答

同花顺怎么把指标改成选股公式

我来帮TA回答

修改同花顺指标为选股公式

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0);
VAR1:=SMA(最佳买入选股,3,1);
VAR2:=SMA(VAR1,3,1),COLOR0000FF;
VAR3:=SMA(VAR2,3,1),COLOR00FFFF;
短线买点:IF(CROSS(VAR2,VAR3) AND (VAR2<40),5,0* 10000);
记得点一下,采纳! 赞一下

请高手帮我把同花顺技术指标改成选股指标

{这个公式在 同花顺 通达信 均测试通过}
VAR1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR2A:=((VAR27+VAR26+VAR20)/3+165)/4;
VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2D:=EMA(VAR2C,7);
VAR2E:=(VAR2A+VAR2C)/2/1.1;
超短:=EMA(VAR2E,3);
短线:=EMA(超短,5);
趋势线:=EMA((VAR2B+VAR2D)/2,2);
KD:趋势线>REF(趋势线,1)AND REF(趋势线,1)<REF(趋势线,2)
AND COUNT(CROSS(超短,短线),3)=1 AND 短线<30;

求高人把同花顺指标修改成选股公式。

amv0:=VOL*(O+C+H+L)/4;
势:=EMA(amv0,21)/EMA(VOL,21);
XG:C>=势 AND REF(C,1)<势;

请将同花顺指标公式修改成同花顺选股公式

XG:CROSS(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),10);


VAR1:=EMA(HHV(HIGH,500),21); 
VAR2:=EMA(HHV(HIGH,250),21); 
VAR3:=EMA(HHV(HIGH,90),21); 
VAR4:=EMA(LLV(LOW,500),21); 
VAR5:=EMA(LLV(LOW,250),21); 
VAR6:=EMA(LLV(LOW,90),21); 
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21); 
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21); 
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21); 
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21); 
VARB:=REF(LOW,1); 
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100; 
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3); 
VARE:=LLV(LOW,30); 
VARF:=HHV(VARD,30); 
VAR10:=IF(MA(CLOSE,58),1,0); 
XG:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10>0;

有没有大师帮忙写一个平台突破的选股公式,但是去除一字板突破的个股,还有次新股,我准备盘中选股,

首先平台突破,要有两个关键参数,时间和涨幅,
下面公式是按照你图中的时间和涨幅设置的,如果想用时间和幅度请自行设置.
参数n是时间,参数n1是百分比,
盘整时间为26日,区间涨幅为小于百分之7(计算方法是区间最高价到区间最低价的距离)
N:=26;

N1:=7;

XG:BARSCOUNT(C)>250 AND NOT(C/REF(C,1)>1.097 AND C=H AND C=O) AND HHV(V,N)<REF(HHV(V,5),N) AND REF(C,REF(HHVBARS(V,5),N)+N)<C AND CROSS(C,REF(HHV(C,N-1),1)) AND HHV(C,N)/LLV(C,N)<1+N1/100;

求选股公式:突破平台整理

这个不用求人,系统自带。打开通达信软件,按CTRL+T,选择C119选股公式就可以了,参数自己设定。其实系统本身很多东西用好了效果都可以。